ar71xx: add profile and build image for the TL-WR720N v3 board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index a1018edad5109cc70c40c76999feb2490abdd2ca..4ac6ba963272c5b67ab9fb7da2d41f854ba6819a 100644 (file)
@@ -72,6 +72,18 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWR720
+       NAME:=TP-LINK TL-WR720N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR720/Description
+       Package set optimized for the TP-LINK TL-WR720N.
+endef
+$(eval $(call Profile,TLWR720))
+
+
 define Profile/TLWA701
        NAME:=TP-LINK TL-WA701N/ND
        PACKAGES:=
 define Profile/TLWA701
        NAME:=TP-LINK TL-WA701N/ND
        PACKAGES:=
@@ -102,6 +114,16 @@ define Profile/TLWA801/Description
 endef
 $(eval $(call Profile,TLWA801))
 
 endef
 $(eval $(call Profile,TLWA801))
 
+define Profile/TLWA830
+       NAME:=TP-LINK TL-WA830RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA830/Description
+       Package set optimized for the TP-LINK TL-WA830RE.
+endef
+$(eval $(call Profile,TLWA830))
+
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
@@ -115,12 +137,12 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR3600/4300/4310
+       NAME:=TP-LINK TL-WDR3500/3600/4300/4310
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWDR4300/Description
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWDR4300/Description
-       Package set optimized for the TP-LINK TL-WDR3600/4300/4310.
+       Package set optimized for the TP-LINK TL-WDR3500/3600/4300/4310.
 endef
 $(eval $(call Profile,TLWDR4300))
 
 endef
 $(eval $(call Profile,TLWDR4300))