ar71xx: add profile and build image for the TL-WR1041N v2 board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index c9f0cacb1eb186d5cec0b77bf6a2668d42456322..5c18c44717252f3bfd38bac90da36bc2d0c7d1e4 100644 (file)
@@ -5,9 +5,20 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR11U
+       NAME:=TP-LINK TL-MR11U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR11U/Description
+       Package set optimized for the TP-LINK TL-MR11U.
+endef
+$(eval $(call Profile,TLMR11U))
+
+
 define Profile/TLMR3020
        NAME:=TP-LINK TL-MR3020
-       PACKAGES:=kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLMR3020/Description
@@ -50,6 +61,17 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWA701
+       NAME:=TP-LINK TL-WA701N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWA701/Description
+       Package set optimized for the TP-LINK TL-WA701N/ND.
+endef
+$(eval $(call Profile,TLWA701))
+
+
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
        PACKAGES:=
@@ -105,6 +127,17 @@ endef
 $(eval $(call Profile,TLWR841))
 
 
+define Profile/TLWR842
+       NAME:=TP-LINK TL-WR842N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR842/Description
+       Package set optimized for the TP-LINK TL-WR842N/ND.
+endef
+$(eval $(call Profile,TLWR842))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=
@@ -116,6 +149,17 @@ endef
 $(eval $(call Profile,TLWR941))
 
 
+define Profile/TLWR1041
+       NAME:=TP-LINK TL-WR1041N
+       PACKAGES:=
+endef
+
+define Profile/TLWR1041/Description
+       Package set optimized for the TP-LINK TL-WR1041N/ND.
+endef
+$(eval $(call Profile,TLWR1041))
+
+
 define Profile/TLWR1043
        NAME:=TP-LINK TL-WR1043N/ND
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -125,3 +169,14 @@ define Profile/TLWR1043/Description
        Package set optimized for the TP-LINK TL-WR1043N/ND.
 endef
 $(eval $(call Profile,TLWR1043))
+
+
+define Profile/TLWR2543
+       NAME:=TP-LINK TL-WR2543N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR2543/Description
+       Package set optimized for the TP-LINK TL-WR2543N/ND.
+endef
+$(eval $(call Profile,TLWR2543))