ar71xx: add profile and build image for TP-LINK TL-WA801N/ND
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 9a0d2ffa1cb6ab2150cac28f0b292f0cb5fc226b..a1018edad5109cc70c40c76999feb2490abdd2ca 100644 (file)
@@ -82,6 +82,26 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA7510
+       NAME:=TP-LINK TL-WA7510N
+       PACKAGES:=
+endef
+
+define Profile/TLWA7510/Description
+       Package set optimized for the TP-LINK TL-WA7510N.
+endef
+$(eval $(call Profile,TLWA7510))
+
+define Profile/TLWA801
+       NAME:=TP-LINK TL-WA801N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWA801/Description
+       Package set optimized for the TP-LINK TL-WA801N/ND.
+endef
+$(eval $(call Profile,TLWA801))
+
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
@@ -94,6 +114,17 @@ endef
 $(eval $(call Profile,TLWA901))
 
 
+define Profile/TLWDR4300
+       NAME:=TP-LINK TL-WDR3600/4300/4310
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR4300/Description
+       Package set optimized for the TP-LINK TL-WDR3600/4300/4310.
+endef
+$(eval $(call Profile,TLWDR4300))
+
+
 define Profile/TLWR740
        NAME:=TP-LINK TL-WR740N/ND
        PACKAGES:=