ar71xx: add profile and build image for the TL-WR710N board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index f554e22fd0cf3bfe0aeeda2926741519ec4d6126..e63aa7ad74e30b59f2916b67fb24ed3481420e72 100644 (file)
@@ -5,6 +5,28 @@
 # See /LICENSE for more information.
 #
 
+define Profile/ARCHERC7
+       NAME:=TP-LINK Archer C7
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ARCHERC7/Description
+       Package set optimized for the TP-LINK Archer C7.
+endef
+$(eval $(call Profile,ARCHERC7))
+
+
+define Profile/TLMR10U
+       NAME:=TP-LINK TL-MR10U
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR10U/Description
+       Package set optimized for the TP-LINK TL-MR10U.
+endef
+$(eval $(call Profile,TLMR10U))
+
+
 define Profile/TLMR11U
        NAME:=TP-LINK TL-MR11U
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -72,6 +94,30 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWR710
+       NAME:=TP-LINK TL-WR710N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR710/Description
+       Package set optimized for the TP-LINK TL-WR710N.
+endef
+$(eval $(call Profile,TLWR710))
+
+
+define Profile/TLWR720
+       NAME:=TP-LINK TL-WR720N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR720/Description
+       Package set optimized for the TP-LINK TL-WR720N.
+endef
+$(eval $(call Profile,TLWR720))
+
+
 define Profile/TLWA701
        NAME:=TP-LINK TL-WA701N/ND
        PACKAGES:=
@@ -102,6 +148,16 @@ define Profile/TLWA801/Description
 endef
 $(eval $(call Profile,TLWA801))
 
+define Profile/TLWA830
+       NAME:=TP-LINK TL-WA830RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA830/Description
+       Package set optimized for the TP-LINK TL-WA830RE.
+endef
+$(eval $(call Profile,TLWA830))
+
 
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
@@ -115,12 +171,12 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR3500/3600/4300/4310
+       NAME:=TP-LINK TL-WDR3500/3600/4300/4310/MW4350R
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWDR4300/Description
-       Package set optimized for the TP-LINK TL-WDR3500/3600/4300/4310.
+       Package set optimized for the TP-LINK TL-WDR3500/3600/4300/4310/MW4350R.
 endef
 $(eval $(call Profile,TLWDR4300))