ramips: add suport for ZBT APE522II
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / ubnt.mk
index dc26956b39da542e9bd32e99f05d9b6afdb98bfc..69b83985bd6623c0d6732399d3e2cc8c0af9f9f1 100644 (file)
@@ -38,6 +38,28 @@ endef
 
 $(eval $(call Profile,UBNTUNIFI))
 
+define Profile/UBNTUNIFIACLITE
+       NAME:=Ubiquiti UniFi AP AC LITE/LR
+       PACKAGES:=kmod-ath10k ath10k-firmware-qca988x
+endef
+
+define Profile/UBNTUNIFIACLITE/Description
+       Package set optimized for the Ubiquiti UniFi AP AC LITE/LR.
+endef
+
+$(eval $(call Profile,UBNTUNIFIACLITE))
+
+define Profile/UBNTUNIFIACPRO
+       NAME:=Ubiquiti UniFi AP AC PRO
+       PACKAGES:=kmod-ath10k ath10k-firmware-qca988x kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTUNIFIACPRO/Description
+       Package set optimized for the Ubiquiti UniFi AP AC PRO.
+endef
+
+$(eval $(call Profile,UBNTUNIFIACPRO))
+
 define Profile/UBNTUNIFIOUTDOOR
        NAME:=Ubiquiti UniFiAP Outdoor
        PACKAGES:=
@@ -49,6 +71,18 @@ endef
 
 $(eval $(call Profile,UBNTUNIFIOUTDOOR))
 
+define Profile/UAPPRO
+       NAME:=Ubiquiti UniFi AP Pro
+       PACKAGES:=
+endef
+
+define Profile/UAPPRO/Description
+       Package set optimized for the Ubiquiti UniFi AP Pro.
+endef
+
+$(eval $(call Profile,UAPPRO))
+
+
 define Profile/UBNT
        NAME:=Ubiquiti Products
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2