ar71xx: add support for the embeddedwireless Dorin board (based on patch by embeddedw...
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 8eed67dc06ac4845ac3edfc295a3b8a8ad18b1f3..0a7d75a3dfa2d0c3cc2513f9e273391bfa5db046 100644 (file)
@@ -675,6 +675,12 @@ define Image/Build/Profile/AP121MINI
        $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,ap121-mini,$(ap121_mini_cmdline),$(ap121_mtdlayout_4M),917504,2818048,RKuImage)
 endef
 
+ew-dorin_cmdline=board=EW-DORIN console=ttyATH0,115200
+ew-dorin_mtdlayout_4M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),896k(kernel),2816k(rootfs),64k(art),3712k@0x50000(firmware)
+define Image/Build/Profile/EWDORIN
+       $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,ew-dorin,$(ew-dorin_cmdline),$(ew-dorin_mtdlayout_4M),917504,2883584,KRuImage)
+endef
+
 ap81_cmdline=board=AP81 console=ttyS0,115200
 define Image/Build/Profile/AP81
        $(call Image/Build/Template/$(fs_64k)/$(1),AthGzip,ap81,$(ap81_cmdline),,1310720,6619136,KRuImage)
@@ -1068,6 +1074,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR615E4,$(1))
        $(call Image/Build/Profile/DIR825B1,$(1))
        $(call Image/Build/Profile/EAP7660D,$(1))
+       $(call Image/Build/Profile/EWDORIN,$(1))
        $(call Image/Build/Profile/FR54RTR,$(1))
        $(call Image/Build/Profile/HORNETUB,$(1))
        $(call Image/Build/Profile/JA76PF,$(1))