ar71xx: Add UBNT airGateway Pro support
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 0becd24857b9e418fc75e79eaebd09cebd9a6558..a8b8ecb8bee664dab1741bb41019dd98273686b7 100644 (file)
@@ -883,6 +883,15 @@ define Device/ubnt-air-gateway
 endef
 TARGET_DEVICES += ubnt-air-gateway
 
+define Device/ubnt-air-gateway-pro
+  $(Device/ubnt-xm)
+  BOARDNAME := UBNT-AGWP
+  UBNT_TYPE := AirGWP
+  UBNT_CHIP := ar934x
+  CONSOLE = ttyS0,115200
+endef
+TARGET_DEVICES += ubnt-air-gateway-pro
+
 define Device/ubdev01
   $(Device/ubnt-xm)
   MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7488k(firmware),64k(certs),256k(cfg)ro,64k(EEPROM)ro