image: remove padding parameter from append-kernel/append-rootfs
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index a8c215b36db11667baab47b413e3549be083c0b2..bce5cd3774457f65c5379a968df447d12b4a2383 100644 (file)
@@ -94,7 +94,7 @@ define Device/Default
   KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma
   COMPILE :=
   IMAGES := sysupgrade.bin
-  IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+  IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
 
 $(eval $(call BuildImage))