ar71xx: move boards to tiny subtarget
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index 613bec8426389cbe04a3bbc7a9f635bccbd27e51..0ff0850621eb6668618715c06c4d31d0bae5eaca 100644 (file)
@@ -16,14 +16,6 @@ define Build/append-string
        echo -n $(1) >> $@
 endef
 
-define Build/mkbuffaloimg
-       $(STAGING_DIR_HOST)/bin/mkbuffaloimg -B $(BOARDNAME) \
-               -R $$(($(subst k, * 1024,$(ROOTFS_SIZE)))) \
-               -K $$(($(subst k, * 1024,$(KERNEL_SIZE)))) \
-               -i $@ -o $@.new
-       mv $@.new $@
-endef
-
 define Build/mkwrggimg
        $(STAGING_DIR_HOST)/bin/mkwrggimg -b \
                -i $@ -o $@.imghdr -d /dev/mtdblock/1 \
@@ -1190,19 +1182,6 @@ define Device/dap-2695-a1
 endef
 TARGET_DEVICES += dap-2695-a1
 
-define Device/bhr-4grv2
-  DEVICE_TITLE := Buffalo BHR-4GRV2
-  BOARDNAME := BHR-4GRV2
-  ROOTFS_SIZE := 14528k
-  KERNEL_SIZE := 1472k
-  IMAGE_SIZE := 16000k
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
-  IMAGES := sysupgrade.bin factory.bin
-  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
-  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
-endef
-TARGET_DEVICES += bhr-4grv2
-
 define Device/wam250
   DEVICE_TITLE := Samsung WAM250
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
@@ -1294,18 +1273,6 @@ define Device/wrtnode2q
 endef
 TARGET_DEVICES += wrtnode2q
 
-define Device/zbt-we1526
-  DEVICE_TITLE := Zbtlink ZBT-WE1526
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
-  BOARDNAME := ZBT-WE1526
-  IMAGE_SIZE := 16000k
-  KERNEL_SIZE := 1472k
-  ROOTFS_SIZE := 14528k
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
-  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
-endef
-TARGET_DEVICES += zbt-we1526
-
 define Device/AVM
   DEVICE_PACKAGES := fritz-tffs -uboot-envtools
   KERNEL := kernel-bin | patch-cmdline | lzma | eva-image