ar71xx: add support for YunCore T830
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index f23c208caf82bfb1dcd5de3a96361982108bc7e1..2158a9921a840b6c3953dad964b720e2da6b17f9 100644 (file)
@@ -910,6 +910,18 @@ define Device/xd3200
 endef
 TARGET_DEVICES += xd3200
 
+define Device/t830
+  DEVICE_TITLE := YunCore T830
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+  BOARDNAME := T830
+  IMAGE_SIZE := 16000k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+  SUPPORTED_DEVICES := t830
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += t830
+
 define Device/tellstick-znet-lite
   $(Device/tplink-16mlzma)
   DEVICE_TITLE := TellStick ZNet Lite