ar71xx: image: use simply expanded variables
[openwrt/openwrt.git] / target / linux / ar71xx / image / mikrotik.mk
index 4047b72feb9cab3723c810217459c9e4f13ef714..7c3374062d92871d6a009631c311069917588999 100644 (file)
@@ -21,7 +21,6 @@ define Device/nand-large
   DEVICE_TITLE := MikroTik RouterBoard with >= 128 MB NAND flash
   KERNEL := kernel-bin | kernel2minor -s 2048 -e -c
 endef
-
 TARGET_DEVICES += nand-64m nand-large
 
 define Device/rb-nor-flash-16M
@@ -32,7 +31,7 @@ define Device/rb-nor-flash-16M
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin | lzma | loader-kernel
   SUPPORTED_DEVICES := rb-750-r2 rb-750up-r2 rb-941-2nd rb-951ui-2nd rb-952ui-5ac2nd rb-962uigs-5hact2hnt rb-lhg-5nd rb-mapl-2nd
-  IMAGE/sysupgrade.bin = append-kernel | kernel2minor -s 1024 -e | pad-to $$$$(BLOCKSIZE) | \
+  IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | pad-to $$$$(BLOCKSIZE) | \
        append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef
 
@@ -41,5 +40,4 @@ define Device/rb-nor-flash-16M-ac
   DEVICE_TITLE := MikroTik RouterBoard with 16 MB SPI NOR flash and ac
   DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x ath10k-firmware-qca9887
 endef
-
 TARGET_DEVICES += rb-nor-flash-16M rb-nor-flash-16M-ac