rtl8366_smi: add Kconfig option for the debugfs stuff
[openwrt/openwrt.git] / target / linux / ar71xx / patches-2.6.31 / 204-rtl8366-smi-driver.patch
index 77874b49f6d6397e20f43db50782434e2d3f4d24..23dc525ece44ff1b13b5540d932d0d63eb56f75f 100644 (file)
@@ -1,12 +1,18 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -140,4 +140,8 @@ config MDIO_GPIO
+@@ -140,4 +140,14 @@ config MDIO_GPIO
          To compile this driver as a module, choose M here: the module
          will be called mdio-gpio.
  
 +config RTL8366_SMI
 +      tristate "Support for RTL8366 switch via SMI interface"
 +      depends on GENERIC_GPIO
++
++config RTL8366_SMI_DEBUG_FS
++      bool "RTL8366S driver DEBUG_FS support"
++      depends on RTL8366_SMI
++      depends on DEBUG_FS
++      default n
 +
  endif # PHYLIB
 --- a/drivers/net/phy/Makefile