add missing kernel config symbols for 2.6.36
[openwrt/openwrt.git] / target / linux / ar71xx / patches-2.6.34 / 202-spi_vsc7385_driver.patch
index b0bb15fcefbf1f08dec6fd3f26c296e7df47676f..f01e0a2de456d00275c8f1b6c55a9c922826852d 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -386,6 +386,11 @@ config SPI_TLE62X0
-         sysfs interface, with each line presented as a kind of GPIO
-         exposing both switch control and diagnostic feedback.
+@@ -399,6 +399,11 @@ config SPI_RB4XX_CPLD
+         SPI driver for the Xilinx CPLD chip present on the
+         MikroTik RB4xx boards.
  
 +config SPI_VSC7385
 +      tristate "Vitesse VSC7385 ethernet switch driver"
@@ -14,9 +14,9 @@
  #
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -57,6 +57,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
+@@ -59,6 +59,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
  # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_RB4XX_CPLD)  += spi_rb4xx_cpld.o
  obj-$(CONFIG_SPI_SPIDEV)      += spidev.o
 +obj-$(CONFIG_SPI_VSC7385)     += spi_vsc7385.o
  obj-$(CONFIG_SPI_TLE62X0)     += tle62x0.o