arc: use patched .dts from sources
[openwrt/openwrt.git] / target / linux / arc770 / image / Makefile
index 47c936e556c1683806f0b51f9265932973cc4341..ca204a4a5543e91daaed1c0ee57cb49a8b4d1391 100644 (file)
@@ -15,7 +15,7 @@ define Build/calculate-ep
 endef
 
 define Build/patch-dtb
-       $(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
+       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
        $(STAGING_DIR_HOST)/bin/patch-dtb $@ $@.dtb
 endef
 
@@ -24,9 +24,8 @@ define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   DEVICE_PROFILE :=
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE
 
 define Device/vmlinux
   KERNEL_SUFFIX := .elf