revamp target: add support for netusg20 board
[openwrt/openwrt.git] / target / linux / at91 / Makefile
index fb04344e2922e6aae611abb355a2d9d7951a4dca..2f86b311d0ceb627163615e11abc4e172c9afef3 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
-FEATURES:=squashfs usb
+BOARDNAME:=NetusG20
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-LINUX_VERSION:=2.6.22.18
+LINUX_VERSION:=2.6.34
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
 define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
+       Build firmware images for Acmesystems NetusG20 board
 endef
 
 $(eval $(call BuildTarget))