build: unify target independent optimization options
[openwrt/openwrt.git] / target / linux / at91 / Makefile
index 90d10088d569922eb886a47e954b7eecc89d17de..e9cc6d1c4912e16dd50772c098e0c0adbe2cbec1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,15 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs targz ext2 usb
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci
 
 $(eval $(call BuildTarget))