at91: separate MKUBIFS opts to defaults in the sub target
[openwrt/openwrt.git] / target / linux / at91 / image / sama5.mk
index 11d8538dffc4bd33003d5cabd1c9613ef0aa39b7..1c779ca32726f73844c8d6480a88ff09d9dd48df 100644 (file)
@@ -1,7 +1,31 @@
+define Device/default-nand
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 2048
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
 define Device/at91-sama5d3_xplained
   $(Device/evaluation-dtb)
   DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
   KERNEL_SIZE := 6144k
-  SUBPAGESIZE := 2048
 endef
 TARGET_DEVICES += at91-sama5d3_xplained
+
+define Device/at91-sama5d2_xplained
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+  KERNEL_SIZE := 6144k
+endef
+TARGET_DEVICES += at91-sama5d2_xplained
+
+define Device/at91-sama5d4_xplained
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+  KERNEL_SIZE := 6144k
+  BLOCKSIZE := 256k
+  PAGESIZE := 4096
+  SUBPAGESIZE := 2048
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+endef
+TARGET_DEVICES += at91-sama5d4_xplained