create firmware image for the Ubiquiti LS-SR71 board
[openwrt/openwrt.git] / target / linux / at91 / patches-2.6.21 / 003-gpio-driver.patch
index aa5a2e32e15ac0fb2ed3c8df27f738f3863c3ffc..b4ef42ddb14f61263f8ff53fd62c6bdee92672dc 100644 (file)
@@ -1,5 +1,7 @@
---- linux-2.6.21.1.orig/arch/arm/mach-at91/gpio.c      2007-04-27 23:49:26.000000000 +0200
-+++ linux-2.6.21.1/arch/arm/mach-at91/gpio.c   2007-05-28 15:30:48.000000000 +0200
+Index: linux-2.6.21.7/arch/arm/mach-at91/gpio.c
+===================================================================
+--- linux-2.6.21.7.orig/arch/arm/mach-at91/gpio.c
++++ linux-2.6.21.7/arch/arm/mach-at91/gpio.c
 @@ -27,6 +27,7 @@
  
  static struct at91_gpio_bank *gpio;
@@ -8,7 +10,7 @@
  
  
  static inline void __iomem *pin_to_controller(unsigned pin)
-@@ -71,9 +72,13 @@
+@@ -71,9 +72,13 @@ int __init_or_module at91_set_GPIO_perip
  {
        void __iomem    *pio = pin_to_controller(pin);
        unsigned        mask = pin_to_mask(pin);
@@ -22,7 +24,7 @@
        __raw_writel(mask, pio + PIO_IDR);
        __raw_writel(mask, pio + (use_pullup ? PIO_PUER : PIO_PUDR));
        __raw_writel(mask, pio + PIO_PER);
-@@ -130,10 +135,13 @@
+@@ -130,10 +135,13 @@ int __init_or_module at91_set_gpio_input
  {
        void __iomem    *pio = pin_to_controller(pin);
        unsigned        mask = pin_to_mask(pin);
@@ -36,7 +38,7 @@
        __raw_writel(mask, pio + PIO_IDR);
        __raw_writel(mask, pio + (use_pullup ? PIO_PUER : PIO_PUDR));
        __raw_writel(mask, pio + PIO_ODR);
-@@ -151,10 +159,13 @@
+@@ -151,10 +159,13 @@ int __init_or_module at91_set_gpio_outpu
  {
        void __iomem    *pio = pin_to_controller(pin);
        unsigned        mask = pin_to_mask(pin);
@@ -50,7 +52,7 @@
        __raw_writel(mask, pio + PIO_IDR);
        __raw_writel(mask, pio + PIO_PUDR);
        __raw_writel(mask, pio + (value ? PIO_SODR : PIO_CODR));
-@@ -262,6 +273,18 @@
+@@ -262,6 +273,18 @@ int at91_get_gpio_value(unsigned pin)
  }
  EXPORT_SYMBOL(at91_get_gpio_value);
  
  /*--------------------------------------------------------------------------*/
  
  #ifdef CONFIG_PM
---- linux-2.6.21.1.orig/drivers/char/Kconfig   2007-05-28 12:22:29.000000000 +0200
-+++ linux-2.6.21.1/drivers/char/Kconfig        2007-05-28 15:37:43.000000000 +0200
-@@ -1087,5 +1087,12 @@
+Index: linux-2.6.21.7/drivers/char/Kconfig
+===================================================================
+--- linux-2.6.21.7.orig/drivers/char/Kconfig
++++ linux-2.6.21.7/drivers/char/Kconfig
+@@ -1087,5 +1087,12 @@ config AT91_SPIDEV
          The SPI driver gives user mode access to this serial
          bus on the AT91RM9200 processor.
  
 +
  endmenu
  
---- linux-2.6.21.1.orig/drivers/char/Makefile  2007-05-28 12:22:29.000000000 +0200
-+++ linux-2.6.21.1/drivers/char/Makefile       2007-05-28 15:38:11.000000000 +0200
-@@ -95,6 +95,7 @@
+Index: linux-2.6.21.7/drivers/char/Makefile
+===================================================================
+--- linux-2.6.21.7.orig/drivers/char/Makefile
++++ linux-2.6.21.7/drivers/char/Makefile
+@@ -95,6 +95,7 @@ obj-$(CONFIG_TANBAC_TB0219)  += tb0219.o
  obj-$(CONFIG_TELCLOCK)                += tlclk.o
  obj-$(CONFIG_AT91_SPI)                += at91_spi.o
  obj-$(CONFIG_AT91_SPIDEV)     += at91_spidev.o
  
  obj-$(CONFIG_WATCHDOG)                += watchdog/
  obj-$(CONFIG_MWAVE)           += mwave/
---- linux-2.6.21.1.orig/drivers/char/vlink_giu.c       1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.21.1/drivers/char/vlink_giu.c    2007-05-28 15:39:47.000000000 +0200
+Index: linux-2.6.21.7/drivers/char/vlink_giu.c
+===================================================================
+--- /dev/null
++++ linux-2.6.21.7/drivers/char/vlink_giu.c
 @@ -0,0 +1,256 @@
 +/*
 + *  Driver for FDL Versalink GPIO