Add support for u-boot
[openwrt/openwrt.git] / target / linux / at91 / patches-2.6.25 / 007-mtd-partition.patch
index 5c0cd3ec629f30dee41422ccee35a8ec7d72a806..503c89200b2e6a299ebe92ef7a0f33b917f07dae 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
-===================================================================
---- linux-2.6.22.19.orig/drivers/mtd/devices/at91_dataflash.c
-+++ linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
+--- a/drivers/mtd/devices/at91_dataflash.c
++++ b/drivers/mtd/devices/at91_dataflash.c
 @@ -175,7 +175,7 @@ static struct mtd_partition static_parti
  };
  #endif
@@ -11,13 +9,11 @@ Index: linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
  
  #endif
  
-Index: linux-2.6.22.19/drivers/mtd/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/drivers/mtd/Kconfig
-+++ linux-2.6.22.19/drivers/mtd/Kconfig
-@@ -168,6 +168,12 @@ config MTD_AFS_PARTS
-         the partition map from the children of the flash node,
-         as described in Documentation/powerpc/booting-without-of.txt.
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -168,6 +168,12 @@ config MTD_OF_PARTS
+         the partition map from the children of the flash node,
+         as described in Documentation/powerpc/booting-without-of.txt.
  
 +config MTD_AT91_PARTS
 +      tristate "Atmel AT91 partitioning support"
@@ -28,11 +24,9 @@ Index: linux-2.6.22.19/drivers/mtd/Kconfig
  comment "User Modules And Translation Layers"
  
  config MTD_CHAR
-Index: linux-2.6.22.19/drivers/mtd/Makefile
-===================================================================
---- linux-2.6.22.19.orig/drivers/mtd/Makefile
-+++ linux-2.6.22.19/drivers/mtd/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CONCAT)     += mtdconcat.o
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
  obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
  obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
  obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o