build: fix subtarget descriptions
[openwrt/openwrt.git] / target / linux / ath25 / Makefile
index ae867e9039f1bde637f46cd0df1f579637bf7f96..86db43fd66f7a1b42b6906ee276e83cd72ac9b80 100644 (file)
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ath25
 BOARDNAME:=Atheros AR231x/AR5312
-FEATURES:=squashfs low_mem
+FEATURES:=squashfs low_mem small_flash
 MAINTAINER:=Sergey Ryazanov <ryazanov.s.a@gmail.com>
 
-KERNEL_PATCHVER:=3.18
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))