ath79: Add support for TP-Link Archer C25 v1
[openwrt/openwrt.git] / target / linux / ath79 / image / Makefile
index cd136b23b9ba0365dcf6a0185bdb2997ccad77a5..734f27e689c9d76abedad8c89f22a24006ba86ae 100644 (file)
@@ -29,8 +29,9 @@ define Build/loader-okli-compile
        $(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0)
 endef
 
+# Arguments: <output name> <kernel offset>
 define Build/loader-okli
-       dd if=$(KDIR)/loader-$(1).gz bs=7680 conv=sync of="$@.new"
+       dd if=$(KDIR)/loader-$(word 1,$(1)).$(LOADER_TYPE) bs=$(word 2,$(1)) conv=sync of="$@.new"
        cat "$@" >> "$@.new"
        mv "$@.new" "$@"
 endef
@@ -70,7 +71,12 @@ include ./generic.mk
 include ./generic-tp-link.mk
 include ./generic-ubnt.mk
 endif
+ifeq ($(SUBTARGET),nand)
+include ./nand.mk
+endif
 ifeq ($(SUBTARGET),tiny)
+include ./tiny.mk
+include ./tiny-netgear.mk
 include ./tiny-tp-link.mk
 endif
 $(eval $(call BuildImage))