ath79: add initial nand support for gl-ar300m
[openwrt/openwrt.git] / target / linux / ath79 / image / Makefile
index 9c789d4e0f08a6ff5fcfb301e7721109766001dc..f4c0c1e3a51edb2beede646edc5888194ed8046d 100644 (file)
@@ -29,8 +29,9 @@ define Build/loader-okli-compile
        $(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0)
 endef
 
+# Arguments: <output name> <kernel offset>
 define Build/loader-okli
-       dd if=$(KDIR)/loader-$(1).gz bs=7680 conv=sync of="$@.new"
+       dd if=$(KDIR)/loader-$(word 1,$(1)).$(LOADER_TYPE) bs=$(word 2,$(1)) conv=sync of="$@.new"
        cat "$@" >> "$@.new"
        mv "$@.new" "$@"
 endef
@@ -48,9 +49,6 @@ define Build/relocate-kernel
        rm -rf $@.relocate
 endef
 
-define Build/copy-file
-       cat "$(1)" > "$@"
-endef
 
 define Device/Default
   ATH_SOC :=
@@ -62,8 +60,10 @@ define Device/Default
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
   COMPILE :=
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin
-  IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs
+  IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef
 
 ifeq ($(SUBTARGET),generic)
@@ -71,4 +71,10 @@ include ./generic.mk
 include ./generic-tp-link.mk
 include ./generic-ubnt.mk
 endif
+ifeq ($(SUBTARGET),nand)
+include ./nand.mk
+endif
+ifeq ($(SUBTARGET),tiny)
+include ./tiny-tp-link.mk
+endif
 $(eval $(call BuildImage))