ath79: enable factory.bin and adjust profile of ECB1750
[openwrt/openwrt.git] / target / linux / ath79 / image / common-tp-link.mk
index 81a557df4871397c5ac58534c9140d6a853b5f56..0b7b0e1935aee95f2bd108aec5e5aef6e764c969 100644 (file)
@@ -1,14 +1,6 @@
 DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION
 DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HWREVADD TPLINK_HVERSION
 
-define Build/uImageArcher
-       mkimage -A $(LINUX_KARCH) \
-               -O linux -T kernel -C $(1) -a $(KERNEL_LOADADDR) \
-               -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
-       @mv $@.new $@
-endef
-
 define Device/tplink-v1
   DEVICE_VENDOR := TP-Link
   TPLINK_HWID := 0x0
@@ -48,12 +40,14 @@ define Device/tplink-4m
   $(Device/tplink-nolzma)
   TPLINK_FLASHLAYOUT := 4M
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-4mlzma
   $(Device/tplink-v1)
   TPLINK_FLASHLAYOUT := 4Mlzma
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-8m
@@ -86,7 +80,7 @@ endef
 
 define Device/tplink-safeloader-uimage
   $(Device/tplink-safeloader)
-  KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
   KERNEL_INITRAMFS := $$(KERNEL)
 endef