ath79: add mikrotik subtarget
[openwrt/openwrt.git] / target / linux / ath79 / image / generic.mk
index 5a0b0ab67e11a264debaf5592b97096b2bb2e345..3ce51cc0d6e9a61be9182bd26263c3427d30d805 100644 (file)
@@ -1,5 +1,4 @@
 include ./common-buffalo.mk
-include ./common-mikrotik.mk
 include ./common-netgear.mk
 include ./common-tp-link.mk
 include ./common-yuncore.mk
@@ -765,19 +764,6 @@ define Device/librerouter_librerouter-v1
 endef
 TARGET_DEVICES += librerouter_librerouter-v1
 
-define Device/mikrotik_routerboard-wap-g-5hact2hnd
-  $(Device/mikrotik)
-  SOC := qca9556
-  DEVICE_MODEL := RouterBOARD wAP G-5HacT2HnD (wAP AC)
-  IMAGE_SIZE := 16256k
-  IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 -e | \
-       pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
-       append-metadata | check-size $$$$(IMAGE_SIZE)
-  DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
-  SUPPORTED_DEVICES += rb-wapg-5hact2hnd
-endef
-TARGET_DEVICES += mikrotik_routerboard-wap-g-5hact2hnd
-
 define Device/nec_wg1200cr
   SOC := qca9563
   DEVICE_VENDOR := NEC