ath79: add support for Joy-IT JT-OR750i
[openwrt/openwrt.git] / target / linux / ath79 / image / generic.mk
index fbcc9d186a6b567aebebd10b1b97fa97d5c52df7..b33a578f19938d38373cef14f411008556e8dac2 100644 (file)
@@ -1369,6 +1369,15 @@ define Device/jjplus_ja76pf2
 endef
 TARGET_DEVICES += jjplus_ja76pf2
 
+define Device/joyit_jt-or750i
+  SOC := qca9531
+  DEVICE_VENDOR := Joy-IT
+  DEVICE_MODEL := JT-OR750i
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+  IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += joyit_jt-or750i
+
 define Device/librerouter_librerouter-v1
   SOC := qca9558
   DEVICE_VENDOR := Librerouter