ath79: add support for devolo WiFi pro 1200e
[openwrt/openwrt.git] / target / linux / ath79 / image / generic.mk
index badfa7cbab16de7c3c95bb36c09f52e70ebf10c8..ef8cf170dea1d4b3477082c82d32d996aff91291 100644 (file)
@@ -138,6 +138,14 @@ define Device/buffalo_wzr-hp-g450h
 endef
 TARGET_DEVICES += buffalo_wzr-hp-g450h
 
+define Device/devolo_dvl1200e
+  ATH_SOC := qca9558
+  DEVICE_TITLE := devolo WiFi pro 1200e
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1200e
+
 define Device/dlink_dir-825-b1
   ATH_SOC := ar7161
   DEVICE_TITLE := D-LINK DIR-825 B1