ath79: add support for devolo WiFi pro 1200e
[openwrt/openwrt.git] / target / linux / ath79 / image / generic.mk
index c6cecc20d3721f07b116f7434cdcab3685ece7c0..ef8cf170dea1d4b3477082c82d32d996aff91291 100644 (file)
@@ -43,6 +43,16 @@ define Build/elecom-header
 
 endef
 
+define Build/nec-fw
+  ( stat -c%s $@ | tr -d "\n" | dd bs=16 count=1 conv=sync; ) >> $@
+  ( \
+    echo -n -e "$(1)" | dd bs=16 count=1 conv=sync; \
+    echo -n "0.0.00" | dd bs=16 count=1 conv=sync; \
+    dd if=$@; \
+  ) > $@.new
+  mv $@.new $@
+endef
+
 define Device/avm_fritz300e
   ATH_SOC := ar7242
   DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
@@ -128,6 +138,14 @@ define Device/buffalo_wzr-hp-g450h
 endef
 TARGET_DEVICES += buffalo_wzr-hp-g450h
 
+define Device/devolo_dvl1200e
+  ATH_SOC := qca9558
+  DEVICE_TITLE := devolo WiFi pro 1200e
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1200e
+
 define Device/dlink_dir-825-b1
   ATH_SOC := ar7161
   DEVICE_TITLE := D-LINK DIR-825 B1
@@ -262,6 +280,19 @@ define Device/iodata_wn-ag300dgr
 endef
 TARGET_DEVICES += iodata_wn-ag300dgr
 
+define Device/nec_wg800hp
+  ATH_SOC := qca9563
+  DEVICE_TITLE := NEC Aterm WG800HP
+  IMAGE_SIZE := 7104k
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+    append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | \
+    xor-image -p 6A57190601121E4C004C1E1201061957 -x | \
+    nec-fw LASER_ATERM
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct-htt
+endef
+TARGET_DEVICES += nec_wg800hp
+
 define Device/ocedo_koala
   ATH_SOC := qca9558
   DEVICE_TITLE := OCEDO Koala