ath79: enable factory.bin and adjust profile of ECB1750
[openwrt/openwrt.git] / target / linux / ath79 / image / tiny-tp-link.mk
index 128ed9882ed9fed83c9af5f6f60164e5ea7b3191..c918c6baa682e78b2b1c204fb9a55dc0a5aef1e7 100644 (file)
@@ -191,6 +191,16 @@ define Device/tplink_tl-wa901nd-v2
 endef
 TARGET_DEVICES += tplink_tl-wa901nd-v2
 
+define Device/tplink_tl-wa901nd-v3
+  $(Device/tplink-4mlzma)
+  SOC := ar9341
+  DEVICE_MODEL := TL-WA901ND
+  DEVICE_VARIANT := v3
+  TPLINK_HWID := 0x09010003
+  SUPPORTED_DEVICES += tl-wa901nd-v3
+endef
+TARGET_DEVICES += tplink_tl-wa901nd-v3
+
 define Device/tplink_tl-wa901nd-v4
   $(Device/tplink-4mlzma)
   SOC := tp9343
@@ -443,7 +453,7 @@ define Device/tplink_tl-wr941-v2
   TPLINK_HWREV := 2
   SUPPORTED_DEVICES += tl-wr941nd
 endef
-#TARGET_DEVICES += tplink_tl-wr941-v2
+TARGET_DEVICES += tplink_tl-wr941-v2
 
 define Device/tplink_tl-wr941-v4
   $(Device/tplink-4m)