ath79: add support for OpenMesh OM2P-HS v3
[openwrt/openwrt.git] / target / linux / ath79 / image / tiny-tp-link.mk
index 6e07d290f9523f1efe6dee1e70cfc8a9bcd6e7e9..c918c6baa682e78b2b1c204fb9a55dc0a5aef1e7 100644 (file)
@@ -106,6 +106,26 @@ define Device/tplink_tl-wa801nd-v1
 endef
 TARGET_DEVICES += tplink_tl-wa801nd-v1
 
+define Device/tplink_tl-wa801nd-v3
+  $(Device/tplink-4mlzma)
+  SOC := qca9533
+  DEVICE_MODEL := TL-WA801ND
+  DEVICE_VARIANT := v3
+  TPLINK_HWID := 0x08010003
+  SUPPORTED_DEVICES += tl-wa801nd-v3
+endef
+TARGET_DEVICES += tplink_tl-wa801nd-v3
+
+define Device/tplink_tl-wa801nd-v4
+  $(Device/tplink-4mlzma)
+  SOC := qca9533
+  DEVICE_MODEL := TL-WA801ND
+  DEVICE_VARIANT := v4
+  TPLINK_HWID := 0x08010004
+  SUPPORTED_DEVICES += tl-wa801nd-v3
+endef
+TARGET_DEVICES += tplink_tl-wa801nd-v4
+
 define Device/tplink_tl-wa830re-v1
   $(Device/tplink-4m)
   SOC := ar7240
@@ -137,6 +157,7 @@ define Device/tplink_tl-wa850re-v2
   TPLINK_HWID := 0x08500002
   DEVICE_PACKAGES := rssileds
   SUPPORTED_DEVICES += tl-wa850re-v2
+  DEFAULT := n
 endef
 TARGET_DEVICES += tplink_tl-wa850re-v2
 
@@ -170,6 +191,16 @@ define Device/tplink_tl-wa901nd-v2
 endef
 TARGET_DEVICES += tplink_tl-wa901nd-v2
 
+define Device/tplink_tl-wa901nd-v3
+  $(Device/tplink-4mlzma)
+  SOC := ar9341
+  DEVICE_MODEL := TL-WA901ND
+  DEVICE_VARIANT := v3
+  TPLINK_HWID := 0x09010003
+  SUPPORTED_DEVICES += tl-wa901nd-v3
+endef
+TARGET_DEVICES += tplink_tl-wa901nd-v3
+
 define Device/tplink_tl-wa901nd-v4
   $(Device/tplink-4mlzma)
   SOC := tp9343