ramips: Fix up GnuBee PC1 DTS file a little
[openwrt/openwrt.git] / target / linux / ath79 / patches-4.14 / 0004-phy-add-ath79-usb-phys.patch
index 38763d2d743bb55ca08b5b48f97af325669d4959..6280baf913ffd3f713babf78ad0c4956d489369c 100644 (file)
@@ -13,10 +13,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
  create mode 100644 drivers/phy/phy-ar7100-usb.c
  create mode 100644 drivers/phy/phy-ar7200-usb.c
 
-Index: linux-4.14.37/drivers/phy/Kconfig
-===================================================================
---- linux-4.14.37.orig/drivers/phy/Kconfig
-+++ linux-4.14.37/drivers/phy/Kconfig
+--- a/drivers/phy/Kconfig
++++ b/drivers/phy/Kconfig
 @@ -15,6 +15,22 @@ config GENERIC_PHY
          phy users can obtain reference to the PHY. All the users of this
          framework should select this config.
@@ -40,10 +38,8 @@ Index: linux-4.14.37/drivers/phy/Kconfig
  config PHY_LPC18XX_USB_OTG
        tristate "NXP LPC18xx/43xx SoC USB OTG PHY driver"
        depends on OF && (ARCH_LPC18XX || COMPILE_TEST)
-Index: linux-4.14.37/drivers/phy/Makefile
-===================================================================
---- linux-4.14.37.orig/drivers/phy/Makefile
-+++ linux-4.14.37/drivers/phy/Makefile
+--- a/drivers/phy/Makefile
++++ b/drivers/phy/Makefile
 @@ -4,6 +4,8 @@
  #
  
@@ -53,10 +49,8 @@ Index: linux-4.14.37/drivers/phy/Makefile
  obj-$(CONFIG_PHY_LPC18XX_USB_OTG)     += phy-lpc18xx-usb-otg.o
  obj-$(CONFIG_PHY_XGENE)                       += phy-xgene.o
  obj-$(CONFIG_PHY_PISTACHIO_USB)               += phy-pistachio-usb.o
-Index: linux-4.14.37/drivers/phy/phy-ar7100-usb.c
-===================================================================
 --- /dev/null
-+++ linux-4.14.37/drivers/phy/phy-ar7100-usb.c
++++ b/drivers/phy/phy-ar7100-usb.c
 @@ -0,0 +1,140 @@
 +/*
 + * Copyright (C) 2018 John Crispin <john@phrozen.org>
@@ -198,10 +192,8 @@ Index: linux-4.14.37/drivers/phy/phy-ar7100-usb.c
 +MODULE_DESCRIPTION("ATH79 USB PHY driver");
 +MODULE_AUTHOR("Alban Bedel <albeu@free.fr>");
 +MODULE_LICENSE("GPL");
-Index: linux-4.14.37/drivers/phy/phy-ar7200-usb.c
-===================================================================
 --- /dev/null
-+++ linux-4.14.37/drivers/phy/phy-ar7200-usb.c
++++ b/drivers/phy/phy-ar7200-usb.c
 @@ -0,0 +1,123 @@
 +/*
 + * Copyright (C) 2015 Alban Bedel <albeu@free.fr>