kernel: move ubnt ledbar driver to a separate package
[openwrt/openwrt.git] / target / linux / ath79 / patches-5.10 / 0003-leds-add-reset-controller-based-driver.patch
index 7505f682abadd57e16d10d24c46e3f2e816dfd48..4a721f2af26a3661ec34ff5d8a3479889d0f5d98 100644 (file)
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -941,6 +941,17 @@ config LEDS_UBNT_LEDBAR
-         To compile this driver as a module, choose M here: the module
-         will be called leds-ubnt-ledbar.
+@@ -931,6 +931,17 @@ config LEDS_ACER_A500
+ source "drivers/leds/blink/Kconfig"
  
 +config LEDS_RESET
 +      tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +MODULE_ALIAS("platform:leds-reset");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -94,6 +94,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS)     += leds
+@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA)              += leds
+ obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o
- obj-$(CONFIG_LEDS_UBNT_LEDBAR)                += leds-ubnt-ledbar.o
 +obj-$(CONFIG_LEDS_RESET)              += leds-reset.o
  
  # LED SPI Drivers