Fix kmod-ipip build (#2092)
[openwrt/openwrt.git] / target / linux / atheros-2.6 / Makefile
index 92f9d361c4f492ff7e9005b22e2d81fee4c0d6c2..814669534f4d9ea6ca7ca2ea1e0fa0d0e9a5bc36 100644 (file)
@@ -9,13 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=atheros
 BOARDNAME:=Atheros
-FEATURES:=jffs2
+FEATURES:=squashfs jffs2
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
-       Build firmware images for Atheros SoC boards (currently AR2315-AR2317)
+       Build firmware images for Atheros SoC boards
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))