refactor atheros system code - also add support for the reset button (sends netlink...
[openwrt/openwrt.git] / target / linux / atheros-2.6 / files / arch / mips / atheros / Makefile
index aff65d723adb53c7b7b6aa2e31d82d02ba85f5fa..2c2b991bc49f22615e56d285cbd0e95cb22553d4 100644 (file)
@@ -3,20 +3,11 @@
 # License.  See the file "COPYING" in the main directory of this archive
 # for more details.
 #
-# Copyright (C) 2003 Atheros Communications, Inc.,  All Rights Reserved.
 # Copyright (C) 2006 FON Technology, SL.
 # Copyright (C) 2006 Imre Kaloz <kaloz@openwrt.org>
 # Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
 #
 
-# Makefile for Atheros ar531x boards
-#
-# Note! Dependencies are done automagically by 'make dep', which also
-# removes any old dependencies. DON'T put your own dependencies here
-# unless it's something special (ie not a .c file).
-#
-
-obj-y += board.o prom.o irq.o
-obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
-obj-$(CONFIG_ATHEROS_AR5315) += ar5315.o
-
+obj-y += board.o prom.o reset.o
+obj-$(CONFIG_ATHEROS_AR5312) += ar5312/
+obj-$(CONFIG_ATHEROS_AR5315) += ar5315/