move another DEFAULT:=y and fix a dependency bug
[openwrt/openwrt.git] / target / linux / au1000-2.6 / Makefile
index 62d9acbdd16b745069db8210282919654808c8a7..25fc776129b40c34cf88eca6bfff5de144f48108 100644 (file)
@@ -6,11 +6,18 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mipsel
+BOARD:=au1000
+BOARDNAME:=AMD Alchemy AU1x00
+FEATURES:=jffs2
+
+define Target/Description
+       Build firmware for AMD Alchemy 1500 boards
+       (e.g. 4G-Systems Mesh/Access Cube ...)
+endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += yamonenv
 
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
@@ -18,5 +25,23 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/Intel
+  NAME:=Intel IPW2200 WiFi
+  PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
+define Profile/Broadcom
+  NAME:=Broadcom BCM43xx WiFi
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
 $(eval $(call BuildKernel))