mvebu: initial support for Marvell Armada 3720 DB board
[openwrt/openwrt.git] / target / linux / au1000 / Makefile
index d7b9f739ab7f6fa2b953555f53456fa21d2f0b79..debc41e978c0cf201ecb2a47289a62fd681b25e4 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=au1000
-BOARDNAME:=AMD Alchemy AU1x00
-FEATURES:=jffs2 usb pci
+BOARDNAME:=RMI/AMD AU1x00
+FEATURES:=squashfs usb pci
+SUBTARGETS:=au1500 au1550
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.22.4
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
-       Build firmware for AMD Alchemy 1500 boards
-       (e.g. 4G-Systems Mesh/Access Cube ...)
+       Build firmware for RMI/AMD Alchemy 1500,1550 boards
+       (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += yamonenv
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini yamonenv
 
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
@@ -27,8 +29,4 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
-
+$(eval $(call BuildTarget))