define a shared IMG_PREFIX variable used as a basename for image files, it contains...
[openwrt/openwrt.git] / target / linux / avr32 / image / Makefile
index 692c325b5e0980abfaca1883b9ad2b61d2c53a90..595a5d9fcfa4c4b58205a1853fef966f9d5eebee 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
@@ -23,7 +22,7 @@ define Image/Prepare
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+       cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
 
        $(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
        mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
@@ -31,7 +30,7 @@ define Image/BuildKernel
                -n 'OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage-lzma
 
-       cp $(KDIR)/uImage-lzma $(BIN_DIR)/openwrt-$(BOARD)-uImage-lzma
+       cp $(KDIR)/uImage-lzma $(BIN_DIR)/$(IMG_PREFIX)-uImage-lzma
 endef
 
 define Image/Build
@@ -43,14 +42,14 @@ define Image/Build/squashfs
        ( \
                dd if=$(KDIR)/uImage bs=1024k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
 endef
 
 define Image/Build/jffs2-64k
        ( \
                dd if=$(KDIR)/uImage bs=1024k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
 endef
 
 $(eval $(call BuildImage))