target: use SPDX license identifiers on Makefiles
[openwrt/openwrt.git] / target / linux / bcm27xx / modules / other.mk
index 077c5e67a8a035ba22ab86bcfe3ac64973fdebc6..2d4aa3c07926212dd01118718b787a52d1386215 100644 (file)
@@ -1,9 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2019 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 define KernelPackage/pwm-bcm2835
   SUBMENU:=$(OTHER_MENU)
@@ -23,23 +20,6 @@ endef
 $(eval $(call KernelPackage,pwm-bcm2835))
 
 
-define KernelPackage/random-bcm2835
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=BCM2835 HW Random Number Generator
-  KCONFIG:= \
-    CONFIG_HW_RANDOM_BCM2835
-  FILES:=$(LINUX_DIR)/drivers/char/hw_random/bcm2835-rng.ko
-  AUTOLOAD:=$(call AutoLoad,11,bcm2835-rng)
-  DEPENDS:=@TARGET_bcm27xx +kmod-random-core
-endef
-
-define KernelPackage/random-bcm2835/description
-  This package contains the Broadcom 2835 HW random number generator driver
-endef
-
-$(eval $(call KernelPackage,random-bcm2835))
-
-
 define KernelPackage/smi-bcm2835
   SUBMENU:=$(OTHER_MENU)
   TITLE:=BCM2835 SMI driver