bcm53xx: switch to kernel 4.14
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 717a44203ad5d494d62cd9ebbe3d30b166bc7567..2af1c7e719d6f55f244576cda1a2f01d5a9ae717 100644 (file)
@@ -13,17 +13,18 @@ FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram oseama otrx \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer