kernel: update 3.10 to 3.10.36
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 591cc99fde0eab60dee926fa17f3a9e96214e296..339e7cddb877c079a55be807ac5ca33e04ac54f7 100644 (file)
@@ -11,8 +11,9 @@ BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.36
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,10 +21,8 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfp -mfloat-abi=softfp
-
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += swconfig
 
 $(eval $(call BuildTarget))