build: add a config option for enabling a testing version of the target kernel
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index edcf137561cfe2312b5b54dfb7367f6d5fb01452..4171a04ee4c858607a7c3fd6b32a20dbd5db3439 100644 (file)
@@ -8,21 +8,25 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
-FEATURES:=squashfs usb pci pcie gpio
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.10.34
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER := 4.19
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))