bcm53xx: early buttons support (without interrupts)
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index daad42b36938f74bbede5b1b25f0a530fdc194b1..519b5a553065e9068da14519cfc87f09dcf6bafc 100644 (file)
@@ -12,6 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
 FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
 
 LINUX_VERSION:=3.14.18
 
@@ -23,6 +24,8 @@ endef
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))