bcm53xx: image: switch Netgear and Buffalo devices to UBI
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 13f26f450919fc7428a6b9fded8a4ba0617688cf..09109e2d2c6142da52588790d040633ca2c3f6e1 100644 (file)
@@ -11,46 +11,87 @@ define Image/Prepare
        rm -f $(KDIR)/fs_mark
        echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
+
+       $(CP) ./ubinize.cfg $(KDIR)
 endef
 
-define Image/Build/Initramfs
-       $(call Image/Build/Initramfs/Chk,bcm4708-netgear-r6250,U12H245T00_NETGEAR,2,initramfs)
+define trx2ndpart/serial
+-a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
 endef
 
-define Image/Build/Initramfs/Chk
-       $(call Image/Build/Initramfs/DTB,$(1))
-       $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(1)-$(4).chk -k $(KDIR)/$(IMG_PREFIX)-$(4)-$(1).trx -b $(2) -r $(3)
+define trx2ndpart/nand-0x20000-0x800
+-a 0x20000 -f $(KDIR)/root-block-0x20000-min-0x800.ubi -a 0x20000 -A $(KDIR)/fs_mark
 endef
 
-define Image/Build/Initramfs/DTB
+# $(1): dts filename (also used for the firmware file).
+# $(2): flash type (not used).
+define Image/Build/initramfs/DTB
        $(call Image/Build/DTB,zImage-initramfs,$(1))
-       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-initramfs-$(1).trx \
+       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-$(1)-initramfs.trx \
                -f $(KDIR)/zImage-initramfs-$(1).lzma
 endef
 
+# $(1): dts filename (also used for the firmware file).
+# $(2): flash type.
 define Image/Build/squashfs/DTB
        $(call Image/Build/DTB,zImage,$(1))
-       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-squashfs-$(1).trx \
+       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-$(1)-squashfs.trx \
                -f $(KDIR)/zImage-$(1).lzma \
-               -a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
-endef
-
-define Image/Build/squashfs/Chk
-       $(call Image/Build/squashfs/DTB,$(1))
-       $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(1)-$(4).chk -k $(KDIR)/$(IMG_PREFIX)-$(4)-$(1).trx -b $(2) -r $(3)
+               $(call trx2ndpart/$(2))
 endef
 
+# $(1): kernel (Linux) image file
+# $(2): dts filename (also used for the firmware file).
 define Image/Build/DTB
        rm -f $(KDIR)/$(1)-$(2).lzma
        rm -f $(KDIR)/$(1)-$(2).dts
-       cat $(KDIR)/$(1) $(LINUX_DIR)/arch/$(ARCH)/boot/dts/$(2).dtb > $(KDIR)/$(1)-$(2).dts;
+       cat $(KDIR)/$(1) $(DTS_DIR)/$(2).dtb > $(KDIR)/$(1)-$(2).dts;
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
 endef
 
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+# $(3): flash type.
+# $(4): device specific magic.
+define Image/Build/AsusTrx
+       $(call Image/Build/$(1)/DTB,$(2),$(3))
+       # TODO: Put magic in TRX file
+       cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+# $(3): flash type.
+define Image/Build/Trx
+       $(call Image/Build/$(1)/DTB,$(2),$(3))
+       cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+# $(3): flash type.
+# $(4): board_id (device specific magic).
+# $(5): region.
+define Image/Build/Chk
+       $(call Image/Build/$(1)/DTB,$(2),$(3))
+       $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx -b $(4) -r $(5)
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
 define Image/Build
-       $(call Image/Build/$(1),$(1))
-       $(call Image/Build/squashfs/Chk,bcm4708-netgear-r6250,U12H245T00_NETGEAR,2,squashfs)
+       ( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
+
+       $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,serial,RT-N18U)
+
+       $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,nand-0x20000-0x800,U12H245T00_NETGEAR,1)
+       $(call Image/Build/Chk,$(1),bcm4708-netgear-r6300-v2,nand-0x20000-0x800,U12H240T00_NETGEAR,1)
+       $(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp,nand-0x20000-0x800)
+       $(call Image/Build/Trx,$(1),bcm47081-buffalo-wzr-600dhp2,nand-0x20000-0x800)
 endef
 
+define Image/Build/Initramfs
+       $(call Image/Build,initramfs)
+endef
 
 $(eval $(call BuildImage))