bcm53xx: add support for Buffalo WZR-1750DHP
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 2acf107b3571aa72ff1d3ae1fac19ca2c08e8bb8..4f225988619376dd6e47be6eb3fd606f25af56ec 100644 (file)
@@ -13,19 +13,23 @@ define Image/Prepare
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
 endef
 
+# $(1): dts filename (also used for the firmware file).
 define Image/Build/initramfs/DTB
        $(call Image/Build/DTB,zImage-initramfs,$(1))
-       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-initramfs-$(1).trx \
+       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-$(1)-initramfs.trx \
                -f $(KDIR)/zImage-initramfs-$(1).lzma
 endef
 
+# $(1): dts filename (also used for the firmware file).
 define Image/Build/squashfs/DTB
        $(call Image/Build/DTB,zImage,$(1))
-       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-squashfs-$(1).trx \
+       $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-$(1)-squashfs.trx \
                -f $(KDIR)/zImage-$(1).lzma \
                -a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
 endef
 
+# $(1): kernel (Linux) image file
+# $(2): dts filename (also used for the firmware file).
 define Image/Build/DTB
        rm -f $(KDIR)/$(1)-$(2).lzma
        rm -f $(KDIR)/$(1)-$(2).dts
@@ -33,14 +37,28 @@ define Image/Build/DTB
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
 endef
 
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+define Image/Build/Trx
+       $(call Image/Build/$(1)/DTB,$(2))
+       cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+# $(3): board_id (device specific magic).
+# $(4): region.
 define Image/Build/Chk
        $(call Image/Build/$(1)/DTB,$(2))
-       $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(1)-$(2).trx -b $(3) -r $(4)
+       $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx -b $(3) -r $(4)
 endef
 
 # $(1): filesystem type (e.g. squashfs, initramfs).
 define Image/Build
-       $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,2)
+       $(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp)
+
+       $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,1)
+       $(call Image/Build/Chk,$(1),bcm4708-netgear-r6300-v2,U12H240T00_NETGEAR,1)
 endef
 
 define Image/Build/Initramfs