build: drop UBI EOF marker from images by default
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 3fe5bc091bba0998d7bb1fc52ef014fabc0e3b92..e2665acefa4a6d013bbd22e86c9f765d06859351 100644 (file)
@@ -83,9 +83,8 @@ define Device/Default
   KERNEL_NAME := zImage
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
   IMAGES := trx
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   PAGESIZE := 2048
-  UBINIZE_OPTS :=
   IMAGE/trx := append-ubi | trx-nand
 endef
 
@@ -118,6 +117,30 @@ define Device/asus-rt-n18u
 endef
 TARGET_DEVICES += asus-rt-n18u
 
+define Device/buffalo-wxr-1900dhp
+  DEVICE_TITLE := Buffalo WXR-1900DHP
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wxr-1900dhp
+
+define Device/buffalo-wzr-600dhp2
+  DEVICE_TITLE := Buffalo WZR-600DHP2
+  DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-600dhp2
+
+define Device/buffalo-wzr-900dhp
+  DEVICE_TITLE := Buffalo WZR-900DHP
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-900dhp
+
+define Device/buffalo-wzr-1750dhp
+  DEVICE_TITLE := Buffalo WZR-1750DHP
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-1750dhp
+
 define Device/dlink
   IMAGES := bin
   IMAGE/bin := append-ubi | seama-nand
@@ -195,9 +218,15 @@ define Device/smartrg-sr400ac
   IMAGE/trx := append-rootfs | trx-serial
 endef
 
+define Device/tenda-ac9
+  DEVICE_TITLE := Tenda AC9
+  DEVICE_PACKAGES := $(USB2_PACKAGES)
+  IMAGES := trx
+  IMAGE/trx := append-rootfs | trx-serial
+endef
+TARGET_DEVICES += tenda-ac9
+
 TARGET_DEVICES += \
-       buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp \
-       buffalo-wxr-1900dhp \
        netgear-r6250 netgear-r6300-v2 netgear-r8000 \
        smartrg-sr400ac