split out profile definitions from Makefiles
[openwrt/openwrt.git] / target / linux / brcm-2.6 / Makefile
index 0d5533194eca499854e7189cdc272d15161cd3c5..a34d2187ae5f756ba1b2d8b81616342c0e2565c8 100644 (file)
@@ -13,30 +13,13 @@ FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+       (e.g. Netgear WGT634U)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))