split out profile definitions from Makefiles
[openwrt/openwrt.git] / target / linux / brcm-2.6 / Makefile
index 7de48ac2a6f4ff88b7154bed25235b91868df8f1..a34d2187ae5f756ba1b2d8b81616342c0e2565c8 100644 (file)
@@ -9,34 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
+       (e.g. Netgear WGT634U)
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))