split out profile definitions from Makefiles
[openwrt/openwrt.git] / target / linux / brcm-2.6 / Makefile
index 8b135072c3bcbb7f2fa4c539edf766e4cee7ca6e..a34d2187ae5f756ba1b2d8b81616342c0e2565c8 100644 (file)
@@ -19,34 +19,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/WGT634U
-  NAME:=Netgear WGT634U
-  PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/WGT634U/Description
-       Package set compatible with the Netgear WGT634U. Contains USB support
-endef
-$(eval $(call Profile,WGT634U))
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))