split out profile definitions from Makefiles
[openwrt/openwrt.git] / target / linux / brcm-2.6 / Makefile
index b2e53bb211572df7f807daaaab70bc881abab973..a34d2187ae5f756ba1b2d8b81616342c0e2565c8 100644 (file)
@@ -6,10 +6,20 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mipsel
+BOARD:=brcm
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
+
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Netgear WGT634U)
+endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))