brcm2708: add support for the new Raspberry Pi Zero W
[openwrt/openwrt.git] / target / linux / brcm2708 / Makefile
index 9d0d921738c81475a5785842ff081f82bf3f305e..244513dfc6307b4b5a94ca1fa3e32ea6a9cd6191 100644 (file)
@@ -1,11 +1,11 @@
 #
 # Copyright (C) 2012-2016 OpenWrt.org
+# Copyright (C) 2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host.mk
 
 ARCH:=arm
 BOARD:=brcm2708
@@ -14,16 +14,21 @@ FEATURES:=ext4 audio usb usbgadget display gpio fpu
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware image for Broadcom BCM27xx SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       brcm2708-gpu-fw \
+       kmod-usb-hid \
+       kmod-sound-core kmod-sound-arm-bcm2835 \
+       kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
+       brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
+
 KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))