kernel: update 3.10 to 3.10.28
[openwrt/openwrt.git] / target / linux / brcm2708 / Makefile
index f8cd6c89885c8ccc16da4e968969399c99ef154a..5457b421426aaa00c5dd3352f24d50945b460489 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,9 +11,11 @@ ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM2708/BCM2835
 FEATURES:=ext4 audio usb usbgadget display gpio
-MAINTAINER:=Ian Ridge <ianridge[at]gmail.com>
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+CPU_TYPE:=arm1176jzf-s
+CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.28
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
@@ -23,6 +25,4 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
-CFLAGS:=-pipe -march=armv6 -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=softfp -marm
-
 $(eval $(call BuildTarget))